027º Aula – SE, E, Ou

Outra funções bem legais são a E e OU.

No colégio chegamos a ver algo a respeito… Mas vale lembrar como cada uma das funções “pensa”.

O “E” junta informação, acumula… Como assim? Eu sempre dou o seguinte exemplo:

– Para se casar com uma filha minha é preciso ser inteligente E de boa família E bonito E com boa formação E rico E charmoso E educado E bom filho… Se não for de boa família, não adianta ser inteligente… se não for bom filho não adianta ser rico… Tem que ter todas essas características… hahahah Ok, não tenho filhas… hahahah

Já o “OU” é menos exigente ele aceita isso OU aquilo, exemplo:

– Meu filho pode trabalhar como diretor OU gerente OU administrativo OU gari OU garçon OU vendedor OU comprador… Desde que trabalhe, pode ser qualquer vaga… hahaha Também não tenho filhos… ahahaha

Mas acho que assim fica claro…

Imagine que eu tenha no caso dos alunos aprovados e reprovados, um outro problema, preciso considerar a frequência deles.

Nesse caso eu pensaria que o aluno deve ter média acima de 7 E frequência acima de 75% para ser aprovado.

Vamos pensar:

Média maior ou igual a 7 –> B2>=7

Frequência maior ou igual a 75% –> C2 >=75%

Mas as duas condições precisam ser verdadeiras:

Então vou usar o “E”

=E(B2>=7;C2>=75%)

O Excel retornará verdadeiro ou falso.

Agora o SE ficou ainda mais interessante, vamos complicar um pouco???

=SE(E(B2>=7;C2>=75%);”Aprovado”;”Reprovado”)

Vale lembrar:

– Toda fórmula ou função deve ser iniciada com o sinal de igual (=)

– Toda função tem um nome no nosso caso: SE / E

– Os critérios de uma função devem ser separados por ponto e vírgula (;)

– Na função E os critérios são:

– Condição 1

– Condição 2

– …. Quantas condições você tiver….

– Na função SE os critérios são:

– Condição (o resultado da função E ser verdadeira)

– Resposta SE verdadeiro (aprovado)

– Resposta SE falso (reprovado)

– Todo texto deve ser colocado entre aspas (“”)

Agora vamos testar a função “OU”?

Lembra que eu vendia doce? A única condição para não pagar frete era gastar 60 reais, mas se a pessoa quiser a entrega no meu bairro, também não paga frete.

Então temos as seguintes condições

Bairro igual a meu bairro –> D1=”Jordanópolis

Valor da compra maior ou igual a 60 reais –> D16>=60

Porém nesse caso, qualquer das condições me satisfaz.

=OU(D1=”Jordanópolis”;D16>=60

O Excel retornará verdadeiro ou falso.

Vale lembrar:

– Toda fórmula ou função deve ser iniciada com o sinal de igual (=)

– Toda função tem um nome no nosso caso: SE / OU

– Os critério de uma função devem ser separados por ponto e vírgula (;)

– Na função OU os critérios são:

– Condição 1

– Condição 2

– …. Quantas condições você tiver….

– Na função SE os critérios são:

– Condição (o resultado da função OU ser verdadeira)

– Resposta SE verdadeiro (Valor da compra)

– Resposta SE falso (valor da compra mais o valor do frete)

– Todo texto deve ser colocado entre aspas (“”)

=SE(OU(D1=”Jordanópolis”;D16>=60);D16;D16+D17)

 

Fácil? Ou ficou alguma dúvida???

Qualquer dúvida: respiroexcel@paganotti.com.br

Arquivo utilizado para a aula – Aula 27

 

 

Deixe um comentário

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão /  Alterar )

Google photo

Está a comentar usando a sua conta Google Terminar Sessão /  Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão /  Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão /  Alterar )

Connecting to %s