026º Aula – Função Se Evitando Erro

Outra coisa legal no SE é uma espécie de tratamento de erro que podemos fazer.

Pense em uma folha de ponto, eu coloco a hora que entro e que saio para ele calcular quantas horas trabalhei.

Na célula D2 vou digitar:

=C2-B2

Enquanto eu não lanço os dois horários ele fica apresentando um erro.

Como faço para evitar que fique aparecendo ########???

Vamos lá:

Se eu não lançar o horário de saída então não retornar nada senão retornar o cálculo.

Como ficaria essa expressão?

=SE(C2=””;””;C2-B2)

Legal não?! Vamos ver como ficou?

Vale lembrar:

– Toda fórmula ou função deve ser iniciada com o sinal de igual (=)

– Toda função tem um nome no nosso caso: SE

– Os critério de uma função devem ser separados por ponto e vírgula (;)

– Na função SE os critérios são:

– Condição (a hora de saida estar preenchida)

– Resposta SE verdadeiro (“” – ou seja em branco, não retornar nada)

– Resposta SE falso (Calculo de hora de saida, menos a hora de entrada)

– Todo texto deve ser colocado entre aspas (“”)

– Quando uso duas aspas juntas (“”), significa NADA.

Fácil? Ou ficou alguma dúvida???

Qualquer dúvida: respiroexcel@paganotti.com.br

Arquivo utilizado para a aula – Aula 26

 

 

Deixe um comentário

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão /  Alterar )

Google photo

Está a comentar usando a sua conta Google Terminar Sessão /  Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão /  Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão /  Alterar )

Connecting to %s